Talk:sendUDPMessage

From Bohemia Interactive Community
Jump to navigation Jump to search

Has anyone used this command with success? (A3 Alpha)
Can't get it to work.
Validated with "wireshark" that no UDP Package was send.

Tried following formats:
sendUDPMessage ["192.168.0.10",30001,"MyMessage"]
sendUDPMessage [[192,168,0,10],30001,"MyMessage"]

Tried them, because descriptions say [ip,port,"Message"] and not ["ip",port,"message"].
So I thought "ip" maybe integers in array format.

So anyone was successfully ?

--HeliJunkie 22:48, 29 March 2013 (CET)

-- Answer
Suma wrote: sendUDPMessage was never intended to be a full featured communication. We have implemented it to connect to a UI prototyping tool, and it was never enabled for a retail version, as it is very raw and incomplete. As for its limitations: it was never intended or tested to be used for targets other than localhost (127.0.0.1). Specifically it does not handle NAT traversal, and it does not care about packet delivery failures.

So, I guess not ;) --tom_48_97 23:11, 29 March 2013 (CET)


--- THANKS
for your answer.
Tried also with localhost, but I think it was never enabled for a retail version says all.
--HeliJunkie 13:43, 30 March 2013 (CET)


Think there is something wrong with the description.
As far as I know:
UDP protocol is connection less, so it can't verify, if the sender recieves the data.
The description says "Returns false if the message has not been delivered".
So this can't be the truth.
Maybe "Returns false if the message could not be send" will be more close to the truth?
--HeliJunkie 14:49, 17 December 2010 (CET)

I've to make some test more to confirm the return behavior, you can be right. I'll update the page as soon as I'll get a final result. Sorry for that I've got a lot of commands to add ATM... tom_48_97 14:52, 17 December 2010 (CET)