Troubleshooting – ArmA: Armed Assault

From Bohemia Interactive Community
Revision as of 23:33, 26 April 2024 by Lou Montana (talk | contribs) (Text replacement - "ciev" to "ceiv")
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

Troubleshooting FAQ

This article's main purpose is to document common problems and solutions to fix those problems in Armed Assault. If none of the problems here describe your situation then please check the BI Troubleshooting forums.

At this moment in time, the BIS troubleshooting forum or this Wiki pages are not an official means of support, you're welcome to post your problems here and perhaps you can help each other out but for official support you should use the information below.

Getting Support

Please note below the official support information for the particular versions of the game:

North American Version (Atari)

This is for the American boxed version or downloaded ArmA via Atari's download portal.

Atari Support Page

Atari's official Support Forum

European Version (505 Games)

505 Games Support Page

The full list of countries where 505 Games will distribute the game (in no particular order): United Kingdom, France, Italy, Spain, Finland, Denmark, Sweden, Norway, Netherlands, Belgium, Luxemburg, South Africa, Australia, New Zealand, Iceland, Ireland, Andorra, San Marino and The Vatican City, Greece, Portugal, Croatia, Serbia and Montenegro, Bosnia, Slovenia, Liechtenstein, Cyprus, Malta, Turkey, Israel, Middle East, Hungary, Romania, Bulgaria and Japan.

German Version (store bought or downloaded version from Metaboli)

Morphicon Support Page

Official German forum

Email Metaboli's support Email (use if you have any problems buying ArmA from Metaboli).

Czech Version (store bought or downloaded version from Sprocket)

Czech support forums


System Drivers

Stay current! Make sure you have the most recent drivers available for your hardware. Older drivers often contain bugs and can cause various performance issues and bugs while playing the game. Hardware manufacturers often work to improve performance through driver updates.


Note: you may need to reinstall DirectX even if you already have 9.0c or Windows Vista - the most recent DirectX 9.0c release is from June 2007.



Patches & Updates

Patches contain various bug fixes and other improvements.

Patches and updates for Armed Assault can be obtained on the ArmA (dead link) website.

Note When you apply an official BI patch, make sure you have all the original game files intact, if you've altered any of the official game files the patch is prone to failure.

Patching and Update Guide

See Update Guide for detailed information what patches and updates are needed depending on your game version.

Demo as Dedicated Server 1.03

BIS released build 5116 (dead link) of ArmADemo.exe on the 12th January 2007 to address a dedicated server crashing with the original multiplayer demo and to improve the server performance.

Patch Issue 64bit systems and v1.02

Upon patching users would get the message ...\sara.pbo not found. Here are to fixes that have proven to allow installation for most users.

  • Fix steps
Download updated patch from Morphicon forum
Right click the file (patch), then Run as... select the administrator account in the bottom and type in the correct password. Then hit Enter. Patch should apply.

Install Issues

ArmA won't install from DVD

I put the ArmA DVD into the drive and nothing happens. Opening explorer and clicking onto DVD drive returns nothing.


  • If the game won't install try setting the DVD's region code to 2. Checking the instruction manual or manufacturers website for your DVD should tell you how to make such a change.
  • Update DVD drive firmware.

SprocketIDeA version will not Activate

A lot of users insert the wrong information in the wrong places.

The CD Key you receive in your confirmation email is the first thing you enter. (It should look something like QRA6-DTSRV-6F85X-FDDL6-D77S1)

After that you continue through the steps at which point you come to a window with the following option: reinstall existing license. This is the one you click on and then enter your purchase reference number and license holder name.

Your license holder name is usually the email address you used during your purchase. In some cases it will be your full name.

Your Purchase Reference Number will look like this: 1-6984A14E84725A If you purchased multiple copies at once the 1 in front will become a 2,3,4 and so on.

When entering your information make sure there are no spaces in front or behind your entry.

ArmAENG.exe is not a valid Windows 32 Application

I've downloaded the Sprocket version of ArmA when I go to run the ArmAENG.exe installation file, I receive an error:

ArmAEng.exe is not a valid Windows 32 Application


The problem is the file becomes corrupt during download, even downloading the file multiple times the file is still corrupt.

Some users report changing their Temp (or TMP) windows environment variable will fix this problem.

An excellent way to make sure the file is complete is to use a download manager to download the file.

Game Issues

ArmA won't start

ArmA fails to load and crashes immediately.

Possible solutions

Here are some things to try that have worked for other people.

  • Have the latest drivers for your hardware. Updating sound, motherboard, video and network drivers have all had some success with some people.
  • Try running the ArmA game as an administrator, right-click the arma.exe and choose Run as.. and then choose the administrator account.
  • Disable all but the default sound device via the Control Panel -> Hardware and Sound -> Sound. ArmA seems to be unable to recognize and use the default sound device from the list and crashes while booting. (thanks to GossamerS for fix!)

ArmA Beta: Unable to Locate IFC22.DLL

Units or vehicles showing erratic behaviour

Before troubleshooting any unexpected in-game occurrences, remove any third-party addons, and run it with only the standard addons it came with.

Royal Flush campaign missing from Queen's Gambit

In order to activate some content it is required to start the game with the syntax -mod=DBE1 (for example: "C:\Games\Armed Assault\arma.exe" -mod=DBE1). This problem may occur if the player directly activates the program executable (arma.exe) or use the default ArmA shortcut. Either edit the default shortcut or make a new one with the required addition.


How do I backup my profile?

Make a copy of your \My Documents\ArmA and \My Documents\ArmA Other Profiles folder. When you uninstall the game this folder remains.


I have a 5 button mouse and I can only get 3 to work

Use mouse configuration program the comes with your mouse to map keyboard keys to the mouse buttons.

ArmA doesn't seem to recognize my TrackIR device

Ensure you have the latest version of TrackIR software and latest game list update. Information can be found here.

How do I bind right-ctrl?

Since 1.05 you can't assign the right ctrl to any actions.

5117 -Changed: Right Ctrl used for key combination instead of left one. (Right Ctrl no longer mapped to any actions.)

Open your Profile file xxx.ArmAProfile in a text editor (like notepad) and search for the line your looking to change, this example uses keyToggleWeapons. Replace it with:


How do I invert mouse for aircraft only?

Swap mouse inputs mapped to Airplane Nose Down / Nose Up like this:

Nose down  'W','UP',Mouse up, Stick Y- Axis
Nose up    'S','DOWN',Mouse down, Stick Y+ Axis

Default mapping is:

Nose down 'W','UP',Mouse down, Stick Y- Axis
Nose up   'S','DOWN',Mouse up, Stick Y+ Axis

Language Issues

ArmA is in the Wrong Language


The Subtitles are available in:

  • German
  • French
  • Italian
  • Russian
  • Czech
  • Polish
  • English

Go to your My Documents folder and locate a subfolder called ArmA. There you will find a file named ArmA.cfg. Open it in a text editor (e.g. Notepad) and on the first line you will find the following text

language="(Enter Desired Language)";

change the language to the one you desire

save the file and lauch ArmA.

Sound Issues


When trying to start ArmA you receive an error Unable to open dynamic link OPENAL32.DLL

When trying to start ArmA you receive an error Unable to install OpenAL / Returned value was: SomeNumber


Download latest OpenAL installer from the OpenAL Website, install it and reboot.

See also ArmA: Missing OpenAL32.DLL

Performance issues

Bad performance with 1.05 patch

The 1.05 introduced a bug related to Postprocess effects computation. To avoid the bug, either set Postprocess to Low, or you could try the 1.05 Beta Patch (dead link)

Various Graphics Card Related Issues

"D3DX9_30 Not Found"

Download the latest version of DirectX 9.0c from Microsoftlink. As of writing (Dec 2006), the December 2006 version includes D3DX9_30.DLL.

This solution also applies to Windows Vista - the installation of DirectX 9.0c (Dec 2006) corrects this problem.

If after installing Direct X 9.0c you still receive the same error. Check to ensure that you have D3DX9_30.DLL on your hard drive. It should be in C:\WINDOWS\system32. If it is not there download the file manually and place it into the folder this ought to resolve your problem.

"Display adapter does not support format D24S8 for X8R8G8B8"

Go to your display properties, open the troubleshooting tab, and set the Hardware acceleration to "Full".

"Cannot create 3D device" (D3DERR_INVALIDCALL)

Upgrade video card. Card with Shader Model 2 or higher is required to run ArmA.

Change the desktop resolution to be the same as the in-game resolution and then re-launch ArmA.

You may also try to update drivers of your graphics card.

"Cannot create system memory surface: 8007000e"

If you are using 1.05 or newer version, use -maxmem=512 command line option to reduce memory footprint.

"Cannot create system memory surface (Error code 8876086c)"

This is caused by third party content using textures with non 2^n (32,64,128,256,etc) dimensions. It may not effect all video cards.

"No entry 'C:\Documents and Settings\[username]\My Documents\ArmA\ArmA.cfg.3D_Performance'."

Delete your ArmA.cfg configuration file in the profile folder (see path in error message).

ATI Crossfire Mode

The Armed Assault demo v1.03 may not run with ATI cards in Crossfire mode. If attempting to run the multiplayer in crossfire mode, the program may start up but hang before loading any graphics but the mouse pointer. If this happens, Esc can be used to end the program. Upon exiting, windows claims that the error was caused by memory not being able to be written. The Armed Assault report file will allude to a driver problem. Turning off Crossfire will allow you to load the demo and play normally. - Plaintiff1

Graphical Issues

Strange Lines In Game

I have a problem in game, there's a double line of shadows that follows me everywhere.

Graphical Issue


If you have a nVidia video adapter than anisotropic mip filter optimization enabled from the nVidia driver settings, set it off.

If you have an ATI video adapter, force the trilinear mipmapping but leave the trilinear optimization enabled because image degrade is almost null but performance take a big drop)

How do I disable the HDR Lighting?

You can't. There are no other light calucations in ArmA than the High Dynamic Range Lighting (HDR Lighting) which also adds environmental immersion, the visual effect also influences the way that the game is played. All models and textures are designed to take advantage of HDR.

No rifles are shown/rifles disappearing

See Missing Rifles Problem.

Multiplayer Issues

Can't use Multiplayer Setup Dialog

Can't use Multiplayer Setup screen. Can't select roles for a mission, can't vote for a mission, and hitting OK will not do anything.


This issue can usually be traced to nVidia's nForce networking controller. The solution is to use a different network card, if available.

Work around to be traced back

Enable native XP2 firewall, or, if using 3rd party firewall, enable Arma and uPnP architecture.

Can't find servers

No servers show up in the serverslist.


Open the file hosts in the directory "C:\WINDOWS\system32\drivers\etc" and delete all entries except " localhost".


Ensure that applications such as PeerGuardian are not blocking GameSpy.

Can't connect on servers

Every attempt to connect to a server fails with an error message saying that the attempt to connect failed.



netsh winsock reset

with cmd.

If it still does not work, make copy of your registry and do the following:

Start Windows in safe mode, go to device manager, show hidden devices and delete the following non-PnP-drivers:

  • HTTP
  • NetBios over TCP/IP
  • TCP-IP
  • Driver for automatic RAS-connection
  • Windows Socket 2.0 Non-IFS

"Bad Version" when joining multi player server

When trying to access our Clan's server, I get a message saying "Bad connection, connection refused by server".

The "Bad Version" message will be shown when the server has equalModRequired active and you try to contact with a different set of modfolders.

"You cannot play/edit this mission it is dependent on downloadable content that has been deleted CAA10"

The tool BIS released that removes the old Beta (1.07 et. al) folders, accidentally have deleted the A-10 addon (which is what the missions in questions require)

Unfortunately the only solution is to reinstall.

Arma crashes when connecting to servers

Any attempt to connect to a server crashes ArmA with an error message "arma has encountered a problem and needs to close"


Solve it by deleting some troublesome MP cache files ~

C:\Documents and Settings\user profile\local settings\application data\ArmA

Delete the ArmA folder, and try to connect to some servers.

"Receiving Mission File" dialog hangs while no mission downloads

When joining a multiplayer game, you can view and join servers but upon connection, the MP dialog hangs at "Receiving Mission File (0kb / 0kb)". This dialog will not move or update.


Your software or hardware firewall is blocking the ports ArmA uses to update your game files. Try disconnecting your router and plugging your cable/dsl modem directly into your PC. (Be sure to start Windows Firewall to continue protection if you do this) If you have a software firewall, make sure that ArmA is "Enabled" or "Unblocked" in your profiles of accepted connections.

If you find that it is your router blocking the ports, you'll need to open UDP ports 2302-2305 for the game to function with a router.

See Also